Using the Standard Templates

This chapter describes the standard templates available for Persistence technical
documents. It includes instructions for using each one, and for how to combine them
to create a manual. This chapter includes the following sections:

Template File Names and Locations
Working With Book Files

Creating Front Matter

Creating Body Sections

Creating Back Matter

This chapter focuses on creating new documents. For information about applying the
templates described here to documents that use old (pre-April 2000) template styles,
see Chapter 1, “Applying the New Template,” in the New Template Description. You can
find this in the Infrastructure cabinet, in the Templates/New_Template_Description
folder.

Prerequisites

This chapter is written for experienced users of FrameMaker and Canterbury.
Therefore, it does not always provide detailed instructions for accomplishing
FrameMaker or Canterbury tasks. For details, refer to the FrameMaker or Canterbury
documentation.
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Notation

Canterbury does not provide a standard notation for describing the location of files in
its repository. Therefore, the Infrastructure team has devised a notation of our own.
Rather than saying “in the XXX cabinet, in the YYY folder,” this document uses the
format Cabinet:Folder, or Cabinet:Folder/Subfolder. Examples are
Infrastructure:Templates and J2EE_Content:apache/commands.

In this chapter, the following terms apply:

m  Book refers to a FrameMaker book file.

m  Manual refers to a document you are preparing for release to customers.

Template File Names and Locations

The standard templates live in the Infrastructure:Templates folder. Table 1 lists the
types of files that can be part of a manual, and the template file to use for each type of
file. Later sections of this chapter describe the process for creating each of the types of
files listed here.

Table 1. Template Files

Type of File Template File to Use For More
Information

Title page cover_template page 4

Generated list (front matter lists, not generated_list_template page 7

the index)

About This Book (preface) about_this_book page 9

Chapter, Appendix, or Part file main_template page 12

API or Command Reference page reference_template page 13

Glossary glossary_template page 16

Index generated_index_template page 17

The template files about_this_book and glossary_template already include standard
shared text from the Infrastructure:Boilerplate folder. Using these pre-made templates
means you do not have to share these sections yourself.
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Working With Book Files

The Canterbury content management system does not have a direct understanding of
the internals of a FrameMaker book file. Instead, it manages book files as unstructured
documents; in other words, as files whose data structure is unknown. For unstructured
documents, Canterbury saves version information, but does not track changes to the
book file itself.

Canterbury considers a FrameMaker book as all of the document files in a folder.
Therefore, when you are assembling a manual, only put FrameMaker files that belong
to the book file into that folder.

Creating a Book

Note:

To create a new book:
1. If there is not already a Canterbury folder allocated to your book, create one now.
2. In the Chrystal Navigator, navigate to the Infrastructure:Templates folder.

3. Right-click the book file empty_book and select View.
FrameMaker opens the empty_book file. At this point it has no files in it. You will
not add any files to this book until after you have imported it into the Canterbury
repository.

4. Select File->Save As and save the new book file in a temporary directory with the
correct name.
Because Canterbury does not recognize book files as FrameMaker structured
documents, you will not see the Canterbury Save As dialog box.

5. In the Chrystal Navigator, select Object->Import->Document to import the book
file from your temporary directory into the allocated Canterbury folder.

Select the imported book file and open it for editing.

Create and add each of the files needed for your book in the repository, using the
templates listed in Table 1 on page 2.

Even if you have not created all of your chapter files, add the standard front and
back matter elements to your book at this point.

Because Canterbury does not treat book files as structured documents, you
cannot add a FrameMaker file to a book directly from the repository. You must
check out any existing files before you can add them to a book.




1 Using the Standard Templates

Checking Out Book Files

If you are not doing book-level operations, such as adding files or generating the Table
of Contents or the Index, you only need to check out the FrameMaker files you are
actually working with. When you need to work with a book file, you check out the
corresponding folder rather than the book itself.

To check out a book file:
1. Select the Canterbury folder that contains the book file.

2. Right-click on the folder name and select Edit.

Canterbury checks out all of the FrameMaker documents in the folder, including
any that are not part of a book file. If there is a FrameMaker book file in the folder,
Canterbury checks out the book file and opens it in FrameMaker.

Creating Front Matter

This section describes the process for creating each of the standard front matter
elements of a Persistence manual.

Front matter includes:

m  Title Page

m  Table of Contents and Other Generated Lists

m  Preface — About This Book

Title Page

The title page of a manual lists the title, the subtitle, the version, and the release date.
The back of the title page contains copyright information, shared from the
Infrastructure:Boilerplate folder.

Figure 1 shows the format of a sample title page.
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Figure 1.  Title Page Format

VERSION 1.0:

JUNE 2000:

The title page contains two text frames:

m  The first text frame contains two lines of text. You can use the first line for the
book’s title and the second line for the book’s subtitle.

m  The second text frame contains the version number (using a global variable that
contains the latest version) and the release date (using a global variable for the
copyright year).

The title of the manual uses the Book Title variable, which is a local variable. When you
assemble a FrameMaker book file, you will import the value of this variable into each
of the files in the book so that the title of the manual appears in the left footer of all
pages. For details, see “Setting the Left Footer” on page 15.
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Note:

To create a title page for your manual:

1.
2.

In FrameMaker, select File=>New.

In the Select Document Template dialog, navigate to the Infrastructure:Templates
folder.

Select cover_template and click OK.

This gives you a new file to use for your cover, which already includes the
standard copyright information.

Double-click the Book Title variable (which contains “Title of Manual” by default)

to open the Variable dialog box.

Click OK at the warning about shared variables.

Because Book Title is a local variable, you can ignore the warning message.

Follow these steps to set the title of your manual by copying it from a global

variable to the local Book Title variable:

a. In the Variable dialog box, click Edit Definition.

b. In the User Variables list, navigate to the global variable that contains the
title of your manual.

c. Select the text in the Definition text box and press CTRL-C to copy this text.

d. In the User Variables list, navigate back to the Book Title variable.

e. Select the text in the Definition text box and press CTRL-V to replace it with
the title of your manual.

f.  Click Change.

g. Click Done, and then click Replace.

In the lower text frame, hide the version variables that do not apply to your

manual.

By default this text frame includes two variables, Latest Version: EJB and Latest

Version: C+ +, both with product-specific condition tags. Hide the one that does

not apply. If neither one applies, hide both and insert the variable that contains the

version number of your product.

Replace MONTH with the correct release date.

If your manual requires specialized copyright information (as specified in the
product’s functional specification), share the appropriate sections from the
Infrastructure:Boilerplate folder.

If the copyright information you need to include is not available in the
Boilerplate folder, please inform a member of the Techcomm Infrastructure team
so that we can provide the necessary information for you to reuse.
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10. Save your title page in the Canterbury folder allocated for your manual.
Canterbury leaves the file checked out for you to work with.

Table of Contents and Other Generated Lists

Note:

Each manual contains a generated Table of Contents. Some manuals also contain other
generated lists, such as a List of Examples. These other lists use the list type List of
Paragraphs, and specify which paragraph type to use as the source. For example, a List
of Examples is derived from the Code Caption and Code Caption Wide tags.

As of April 2000, Persistence technical manuals no longer include a List of Figures or
a List of Tables.

Defining a Generated List

The process of defining a generated list contains three stages, each of which is
described in detail below:

m  Inserting a reference to a generated list into your book file.

Until you generate the list, there is no actual file with the name that appears in the
book file. If you generate the list at this point, FrameMaker uses default formatting
based on the first file in the book. But this may not be what you want.

m  Creating a properly-formatted skeleton file with the name that FrameMaker
assigned to the reference.

By creating this file before you generate the list, you eliminate the need to import
formats from a template file into a list file in which FrameMaker assigned
unwanted default formats.

m  Generating the list into the skeleton file.

Adding a Generated List to a Book File

To insert a reference to a generated list into your book:

1. In your book file, select File>Add File.

m  For a Table of Contents, select Generated List: Table of Contents, and click
Add.
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2.

3.

m  For a List of Examples, select Generated List: List of Paragraphs, and click
Add.
Based on the type of list, do one of the following:

m  To define a Table of Contents, in the Set Up Table of Contents dialog box,
include the following paragraph tags:

= Appendix m  Head Class

= Chapter = Head Class Single
m  Head 1 m  Head Method

m  Head 2 m  Head Section

= Head 2 Split m  Part

m  To define a List of Examples, in the Set Up List of Paragraphs dialog box,
include the paragraph tags Code Caption and Code Caption Wide.

Click Set.

You should see a reference to the new file in your book, with the name
booknameTOC for a Table of Contents or booknameLOP for a List of Examples.

Before you generate the list, follow these steps to create an empty (“skeleton”) list file:

1.
2.

Select File=>New.

In the Select Document Template dialog, navigate to the Infrastructure:Templates
folder.

Select generated_list_template and click OK.

This gives you an empty file with the proper paragraph catalog and reference page
definitions for your generated list.

In your new file, hide the Comment condition tag and do one of the following:

m  For a Table of Contents, remove the paragraph that says List of Examples.

m  For a List of Examples, remove the paragraph that says Table of Contents.

Save the skeleton file in the Canterbury folder allocated for your manual, using the
name that FrameMaker assigned to the generated list in step 3.

Warning: When you save the skeleton file, you must match the name FrameMaker used when
you inserted the reference to the generated file into your book in step 3.
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Once you have a skeleton file, which Canterbury has left checked out for you, you can
generate the list:

1. In the book file, select File->Generate/Update to generate your list.
2. Open the generated list and verify that the result is what you expect.

Preface — About This Book

Each Persistence technical manual has a preface that follows the generated lists. The
preface contains:

m  Basic information about the purpose of the manual and the intended audience

m  Standard sections that list typographic conventions, related documents, and
contact information

To create a preface for your manual:

1. Select File>New.

2. In the Select Document Template dialog, navigate to the Infrastructure:Templates
folder.

3. Select about_this_book and click OK.
This gives you a new preface file to customize for your manual. Notice that the
title of this chapter appears twice.
m  The first version, “About This Guide,” is for printed manuals (using the
Book-only condition tag).

m  Thesecond version, “About Title of Manual,” is for HTML versions (using the
Online-only condition tag). When you set the Book Title variable for your
book, the Online-only title will be correct (see “Headers and Footers” on
page 14).

Notice also that initially, with both conditions showing, the right page footer

contains both titles, and therefore looks funny. When you hide the Online-only tag

and show the Book-only tag for printing, the footer will be correct.

4. Modify the book-specific sections, such as the Introduction and Intended
Audience, as needed.

5. Inthe “Related Documentation” section, remove the reference to your manual and
hide conditional tags that do not apply to your product.

The references to each manual are shared as individual components, rather than as
entire lists, to enable you to remove the reference to the current manual.
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Note:

Warning:

If you discover inaccuracies or missing standard information that belongs in the
preface template, let someone on the Techcomm Infrastructure team know so
that we can fix things.

6. Save the new file in the Canterbury folder allocated to your book, with a name
such as abouttopic.

Canterbury leaves the file checked out for you to work with.

To make the online Documentation Library work properly, all of the aboutbook
files in the documentation set must have unique names.

Creating Body Sections

The main content of a manual follows the preface. For the most part, you will not write
original material directly into chapters that are part of a book file. Instead, you will
create reusable content in a content cabinet, and share material from this cabinet into
the book cabinet.

Body sections of a manual include:
m  Reusable Content

m  Part Pages

m  Chapters and Appendices

L]

API and Command Reference Pages

Reusable Content

Reusable content refers to common information that can be shared by more than one
manual. This includes concepts, processes, principles, procedures, and facts. For more
information about each of these types of reusable content, see XXX in the Style Guide.

Canterbury recommends that you not include text insets within text insets, because of
long-standing FrameMaker bugs. Therefore, when you create reusable content, instead
of sharing existing content into your new sections, just create each section as a separate
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unit. Instead of sharing an entire document that contains an inset, you can share the
text above the inset, share the text of the inset by sharing its source, and then share the
text below the inset.

To create a shell file that will contain shared content:

1. Select File=>New.

2. In the Select Document Template dialog, navigate to the Infrastructure:Templates
folder.

3. Select main_template and click OK.
This gives you an empty file in which to create your content.

Delete all of the text on the page.

Select Format->Page Layout->Master Page Usage, and under Use Master Page,
select Right/Left.

Since reusable sections are generic, they do not need to use the First master page.

6. Write the text, and save the file in the appropriate folder in the content cabinet.

When you share content that includes graphics, Canterbury resolves references to
the shared graphics correctly.

Part Pages

Part pages introduce groups of related chapters or related API reference pages in a
manual. Part pages use the Part paragraph tag for the part title, and a specialized cross-
reference format, PartXref, for the part number at the top of the page.

Each part page describes in a general way the relationship among the documents in
that part, followed by a list of the documents.
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Figure 2. Sample Part Page (partial)

PartDesc{[tag —> ovorviow focuses on the Wob component: gonoratad [SPs, the wob sorvor, tho sory lot

use PartXrefcross-
reference fonmat ’ P A R | I

Developing Web Clients

The first part of this guide describes how to use Weob clionts - either by genorating
ISPs with PoweorPage, or by writing serviels or applots.

ZPTOC {itay —> Chapter 1, “Web-Based PowerT ier Applications”

Introduces the PowerTier end-to-end solution for entorprise Web applications. T he

ongine, and |SP engino. .......... e AZO D

Chapter 2, “Cetting Started With A Web Sample”
Walks vou through the stops of generating axde, compiling, and running a sample
application............ e page 17

To create a part page:

1.
2.

Select File=>New.

In the Select Document Template dialog, navigate to the Infrastructure:Templates
folder.

Select main_template and click OK.

This gives you a generic chapter file.

Change the text of the default chapter title to your part title.

Change the paragraph tag of the part title to Part. Do not delete the cross-reference
marker at the beginning of the line.

The Part paragraph tag has a hidden autonumber string containing the part
number. You will use this to display the part number instead of the chapter
number.

Double-click the cross-reference to the chapter number at the top of the page and
change the cross-reference format to PartXref.

Because you did not delete the cross-reference marker, the Cross-Reference dialog
already points to your Part paragraph.
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7. Add an introductory paragraph that describes the part, followed by a list of the

documents in the part, following the format in Figure 2.
This list uses two special paragraph tags: zPTOC and PartDesc.
m  Use the zPTOC paragraph tag for a cross-reference to the file name.

m  Use the PartDesc tag for a description of the contents of that file. At the end
of the description, press TAB and add a cross-reference to the first page of
the chapter.

Save the part page in the Canterbury folder allocated for your manual, and add it
to your book file.

Canterbury leaves the file checked out for you to work with.

Chapters and Appendices

Chapter and Appendix files contain the main content of conceptual manuals. Both
types of files use the same format, except for the chapter or appendix title itself. To
create a chapter or appendix file, you create an empty “shell” file, and share
information from the appropriate content cabinet folders into this shell.

For information about sharing content and minimizing nested insets, see XXX.

To create a chapter or appendix file for your manual:

1.
2.

Select File>New.

In the Select Document Template dialog, navigate to the Infrastructure:Templates
folder.

Select main_template and click OK.

This gives you a generic chapter file. You cannot share reusable content from the
repository until you save the new file into Canterbury.

Change the text of the default chapter title to your chapter or appendix title.
Change the paragraph tag to Appendix, if appropriate. Do not delete the cross-
reference marker at the beginning of the line.

The default cross-reference to the chapter or appendix number should still be
correct. You do not need to change it.

Create the necessary sections, using shared information from the content cabinet.
Save the chapter or appendix file in the Canterbury folder allocated for your
manual, and add it to your book file.

Canterbury leaves the file checked out for you to work with.

In the book file, for the first chapter following the preface, select File>Set Up File
and set the Page Numbering to Restart at 1.

13



1 Using the Standard Templates

API and Command Reference Pages

API and command reference pages contain structured information describing a class
and its methods, a command or script file, or a configuration file. These pages use a
template that omits the chapter template’s side-head gutter, to make more room
available for syntax descriptions with long lines.

When you create reference pages, store them in the appropriate folder of the content
cabinet. When you need to include a reference description in a manual, create a “shell”
file for each API or command reference page and share the content into it. For more
details about sharing information, see XXX.

To create a reference page:

1.
2.

Select File=>New.

In the Select Document Template dialog, navigate to the Infrastructure:Templates
folder.

Select reference_template and click OK.

This gives you an empty file into which to add the reference information.
Write the necessary descriptive information.

Save the API or command reference page in the repository.

Canterbury leaves the file checked out for you to work with.

If the information on this reference page is part of a specific manual, create a new
shell file based on reference_template in your book’s folder, and share the
reference information into that file.

Headers and Footers
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In a book, the left page footer always contains the title of the manual. The right page
footer’s contents depend on the type of file and where you are in the book:

In generated lists, the preface, the glossary, the index, and on part pages, the right
page footer contains the title (from the Head Contents, Head Section, or Part
paragraph tag).

In chapter and appendix files and API reference pages, the right page footer
contains the part number and name, if the book has parts.

In books with no parts, the right page footer is blank in chapter and appendix files
and API reference pages.
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Setting the Left Footer

The variable Book Title appears on the Left and landscapelft master pages to display
the title of the manual. For each file you add to your book, you must replace this
variable with the variable that contains the manual’s actual name. You can do this all
at once after adding all the files to your book.

For information about setting the correct value of the Book Title variable, see step 6 on
page 6.

To set the left footer:

1. Open the title page of your book.

2. From the book file, import variable definitions from the title page into all of the
files in your book.

3. If you add new chapter files to your book after you import the Book Title value,
import the variable definitions into these new files to set the left footers correctly.

Setting the Right Footer

If your book contains parts, then in each of the files in each part, you must cross-
reference the part title in the right page footers (on master pages Right, First, and
landscapeRt. If your book does not have parts, you can skip this section.

To set the part number cross-reference follow these steps for each part in your book:
1. Open the part page, if it is not already open, and minimize it.

You will not change this file, but it must be open so you can create cross-references
to the part number and title.

Open the first document in the part.
Select View—>Master Pages to display master pages.
Page up or down to the Right master page.

U -

Replace the Running H/F 4 variable with a cross-reference to the Part paragraph
that contains the part title. Use the Part Footer cross-reference format.

6. Repeat this process for the First master page (in chapter and appendix files only)
and the landscapeRt master page.

7. Save your changes.
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Note:

In each part, you can repeat steps 3—6 for each file as you add it to the book, or you
can do it for the first file in each part and import page layouts from that file into the
other files of the same type in that part. Be sure to import page layouts only into files
that are based on the same template. In other words, you can import page layouts
from a chapter file to other chapter and appendix files, but not to API reference

pages.

Creating Back Matter

This section describes how to create each of the standard back matter elements of a
Persistence manual.

Back matter includes:
m  Glossary

m  Index

Glossary

Note:
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The standard glossary contains all of the terms that might be needed by any
Persistence technical manual. Terms specific to a particular product, domain, or
manual are marked with condition tags corresponding to the associated product,
domain, or manual. When you create a glossary for a manual, you start with the
standard glossary, and hide the condition tags that do not apply to your manual.

The Infrastructure:Templates folder contains a template to use for adding the standard
glossary to your book. This file predefines the correct format and in shares the current
glossary source from the Infrastructure:Boilerplate folder as an inset. When you create
a glossary, you start with this template, not the boilerplate glossary source.

If information in the standard Glossary is incorrect, or if you need to add new terms,
please inform a member of the Techcomm Infrastructure team. See XX in the Style
Guide for a description of the process of adding or changing glossary entries.

Not all manuals include a glossary. Refer to the Style Guide for guidelines on when to
include a glossary in your manual.
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To create a glossary for your manual:

1.
2.

Select File>New.

In the Select Document Template dialog, navigate to the Infrastructure:Templates
folder.

Select glossary_template and click OK.
This gives you a new file that includes the standard glossary as an inset.
Hide condition tags that do not apply to your manual.

Save the new glossary file in the Canterbury folder allocated for your manual, and
add it to your book file.

Canterbury leaves the file checked out for you to work with.

The process of defining an index contains three stages, each of which is described in
detail below:

Inserting a reference to the index into your book file.

Until you generate the index, there is no actual file with the name that appears in
the book file. If you generate the index at this point, FrameMaker uses default
formatting based on the first file in the book. But this may not be what you want.

Creating a properly-formatted skeleton file with the name that FrameMaker
assigned to the reference.

By creating this file before you generate the index, you eliminate the need to
import formats from a template into a list file to which FrameMaker assigned
unwanted default formats.

Generating the index into the skeleton file.

For conventions and procedures for defining index entries, see XXX in the Style Guide.

To insert a reference to the Index into your book:

1.

2
3.
4

In your book file, select File>Add File.
Select Generated Index: Standard Index, and click Add.
In the Set Up Standard Index dialog box, include markers of type Index.

Click Set.
You should see the new file listed in your book, with the name booknamelX.

Before you generate the Index, follow these steps to create an empty (“skeleton”) Index

file:
1.

Select File=>New.
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2. In the Select Document Template dialog, navigate to the Infrastructure:Templates
folder.

3. Select generated_index_template and click OK.
This gives you an empty file with the proper page layouts, paragraph catalog, and
reference page definitions for your index.

4. Save the file in the Canterbury folder allocated for your manual, using the name
that FrameMaker assigned to the generated list.

Warning: When you save the skeleton file, you must match the name FrameMaker used when
you added the generated file to your book in step 4.

Once you have a skeleton file, which Canterbury has left checked out for you, you can
generate the Index:

1. Add index markers in the appropriate locations in the chapters of your manual.
2. In the book file, select File>Generate/Update to generate your Index.
3. Verify that the result is what you expect.
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