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3 Creating a Sample Mapping

This chapter presents a walkthrough of the mapping process, using a sample 
database, based on a hypothetical Web site called AutoSource. Using this site, 
users can get price quotes for a variety of cars. To do this, they specify the make 
and model, and select a trim package. The trim package represents the features of a 
particular model, including its appearance and associated options packages. 
Many trim packages also have photographs that users can see.

The example in this chapter focuses on a database of trim packages provided by 
AcmeAuto for the AutoSource site. The AcmeAuto database contains two tables, 
whose internal structure might or might not be compatible with the data formats 
that the AutoSource database uses to display cars to visitors of that site. 

In this example, you map data elements from an ATS schema to mapping targets 
in the Abstract Conceptual Model. From these mappings, you will generate a 
mapping specification.

You will see how to use the Modulant Balisarda Mapping Tool to create the 
mappings between the elements of the AcmeAuto database to elements of the 
Abstract Conceptual Model so that they can be transformed into a format that the 
AutoSource site can understand and display for users. 

This walkthrough follows the stages discussed in Chapter 2, “The Mapping 
Process,” and includes the following sections:

Introducing the AcmeAuto Database

Identifying the Mapping Targets

Importing the ATS Schema

Mapping Data Elements

Defining the Transformation

Creating a Mapping Specification

Testing a Mapping Specification
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Introducing the AcmeAuto Database
The AcmeAuto database used by the AutoSource Web site has two tables: 

ACME_TRIM contains the characteristics of each trim package.

ACME_TRIM_IMAGE contains a URL pointing to a photograph of each trim 
package, with information about the graphics file format.

Figure 7 shows the structure of the sample database, in EXPRESS-G graphical 
notation. For information about the symbols in this diagram, see Appendix A, 
“EXPRESS-G Language Notation.”

Figure 7: The AcmeAuto Database

Table 1 shows the attributes of the ACME_TRIM table, and Table 2 shows the 
attributes of the ACME_TRIM_IMAGE table.

Table 1: ACME_TRIM Table

Attribute Data Type Description

TRIM_NBR String A unique identifier for each trim package.

TRIM_NAME String The name of the trim package.

TRIM_COLOR String The exact color specification of cars with a 
particular trim package; for example, Powder 
Blue.

COLOR_CODE String An abbreviation of a high-level classification 
of color; for example, B (for blue).
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Identifying the Mapping Targets
To map the data elements in the AcmeAuto database effectively, you need to 
understand more about the meaning of each element and how they are used. 
Before you begin creating any mappings, it is important to identify the mapping 
targets in the Abstract Conceptual Model. This is a complex process, and requires 
a thorough grasp of the structure of the Abstract Conceptual Model. 

Figure 8 shows a subset of the Abstract Conceptual Model with all of the target 
elements you will use in this example, and the relationships between those 
elements. The rest of this discussion centers on how you create this mapping. For 
more details about the target data elements, see Chapter 4, “Understanding the 
Abstract Conceptual Model.”

This figure shows the structure of the Abstract Conceptual Model in EXPRESS-G 
graphical notation. 

T_MAKE String The manufacturer of the car.

T_MODEL String The model of the car.

Table 2: ACME_TRIM_IMAGE Table

Attribute Data Type Description

TRIM_NBR String Identifies a trim package. This attribute is a 
migrated key representing TRIM_NBR in the 
ACME_TRIM table. Combines with T_IMAGE to 
provide a primary key.

TRIM_NAME String The name of the trim package. This attribute 
is the same as TRIM_NAME in the ACME_TRIM 
table.

IMAGE_TYPE String The file type of the graphic image.

T_IMAGE String A URL pointing to a graphic file containing 
the image of the trim package.

TRIM ACME_TRIM Identifies the relationship between this table 
and the ACME_TRIM table—each trim image 
represents a particular trim package.

Table 1: ACME_TRIM Table

Attribute Data Type Description
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Figure 8: Target Data Elements in the Abstract Conceptual Model

Table 3 shows where to map each of the data elements in the AcmeAuto database. 
The rest of this walkthrough shows you how to create the mappings. All mapping 
targets for data elements use the notation entity_name.attribute_name. When you 
create mappings, you always map data elements from the source ATS schema to 
attributes of entities in the Abstract Conceptual Model, never directly to the 
entities.

This table only shows the primary mapping target for each source data element. 
As you create each mapping, you will add references to other entities shown in 
Figure 8 to create paths between entities you have used as mapping targets. For 
specifics, see “Mapping Related Data Elements” on page 37.
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This table does not capture the context information you will add to the mapping. 
In this walkthrough, you will see how to specify the context at the appropriate 
points in the process. For more information about determining where to add 
information about context in a mapping, see Chapter 5, “Developing a Mapping 
Strategy.”

Table 3: Mapping Strategy for the AcmeAuto Database 

Source Data Element Mapping Target Explanation

ACME_TRIM: TRIM_NBR product.id This is the root element of the 
ACME_TRIM table. The main strategy is 
to treat each trim package as a product.

ACME_TRIM: TRIM_NAME product.name This is name of the trim package; it 
identifies which product you are 
talking about.

ACME_TRIM: TRIM_COLOR group.name Colors provide a classification scheme 
for trim packages. The group entity in 
the Abstract Conceptual Model 
represents classifications. The attribute 
group.name has unique values, as does 
ACME_TRIM: TRIM_COLOR.

ACME_TRIM: COLOR_CODE group.name The color code provides an additional 
level of classification, beyond the trim 
color. This creates a group that contains 
groups of trim colors.

ACME_TRIM: T_MAKE organization.
identifier

The manufacturer of a line of cars can 
be thought of as an organization—the 
company who makes the cars. 

ACME_TRIM: T_MODEL group.name The model name of a car provides a 
way to classify the cars made by a 
particular manufacturer. 

ACME_TRIM_IMAGE: TRIM_NBR product.id Same as ACME_TRIM: TRIM_NBR. 

ACME_TRIM_IMAGE: TRIM_NAME product.name Same as ACME_TRIM: TRIM_NAME. 

ACME_TRIM_IMAGE: IMAGE_TYPE document_type.
product_data_type

The type of image file represents what 
type of document contains the image.

ACME_TRIM_IMAGE: T_IMAGE document.id The URL pointing to the photograph of 
each trim package provides a way to 
document what that trim package 
looks like.

ACME_TRIM_IMAGE: TRIM skip this one Since this is a reference back to the 
ACME_TRIM table, do not map this data 
element explicitly.
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Notice that a decision was made to map the idea of an AcmeAuto trim package to 
a product. This reflects how the application using this data thinks about each trim 
package. In other words, a trim package can be treated the same way as the 
application treats other products.

Notice also that several data elements are mapped to group.name. As the name 
suggests, many of the entities in the Abstract Conceptual Model are abstract. That 
is, like group, they can contain different categories of the same data. The entities 
group, person, and organization are examples of abstract entities. 

You can use the idea of a group in the Abstract Conceptual Model to categorize a 
number of different things. When you add contextual information to each 
mapping, you distinguish among the different groups. In this example, colors and 
model names represent separate groups.

With the basics of the mapping strategy identified, you can start the next stage of 
the mapping process. 

Importing the ATS Schema
The sample AcmeAuto database is defined as an EXPRESS schema. For a brief 
description of EXPRESS, see “The EXPRESS Data Modeling Language” on page 7. 
For a more thorough description of EXPRESS, see the resources provided by the 
Universal Data Interoperability Framework at www.UDIF.org.

Before you can specify the ATS schema you want to map, you must start the 
Modulant Balisarda Mapping Tool and specify the locations of your working 
database and the Abstract Conceptual Model. Then you can specify the format 
and location of your ATS schema.

This section describes the following tasks:

Starting the Modulant Balisarda Mapping Tool

Importing the ATS Schema

Starting the Modulant Balisarda Mapping Tool
Before you can start the Mapping Tool, you must do the following things:

Start the Modulant Curtana Analyst Tool

Make a Copy of the Working Database

Specify a Database Connection

Specify the Abstract Conceptual Model’s Location

http://www.UDIF.org
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Make a Copy of the Working Database
Before you begin, follow these steps to make a copy of the working database that 
the Mapping Tool uses to store information about the mappings you define:

1 Using Windows Explorer, navigate to the samples directory of your Modulant 
Curtana installation.

2 Select the Access database walkthrough-empty.mdb.
3 Select Edit>Copy, and then select Edit>Paste to place a copy of this database 

in the samples directory.
4 Change the name of the copy from Copy of walkthrough-empty.mdb to 

mt-walkthrough.mdb.

Start the Modulant Curtana Analyst Tool
To begin creating a mapping, you must start the Analyst Tool, as follows:

From the Windows desktop, select Start>Programs>Modulant>Modulant 
Curtana.
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The Modulant Curtana Analyst Tool main window appears:

From here, you will start the Modulant Balisarda Mapping Tool. Before you can 
create a mapping, you must specify connection information for the internal 
database that the Mapping Tool uses to store information as you work. The 
Mapping Tool will use this information to generate an XMP mapping 
specification.
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Specify a Database Connection
To specify a database connection:

1 At the top of the Analyst Tool window, next to Database Connection, click 
Edit.

The Edit Database Connection dialog box appears:

2 In the Name field, type a name to represent your database. For this example, 
type walkthrough.

3 Click Browse to search for the database file. For this example, use the Access 
database mt-walkthrough.mdb you created in the samples subdirectory of 
your Modulant Curtana installation.

4 Leave the User ID and Password fields blank.
5 Click Add to add the connection information to the list at the top.
6 Click Close.

Make sure that the walkthrough database connection you defined is now 
selected in the Database Connection field.
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Specify the Abstract Conceptual Model’s Location
To specify the location of the Abstract Conceptual Model schema file:

1 On the Design tab, click the Preferences button.

The Preferences dialog box appears:

2 In the Next Request ID field, type 2.

The Request ID corresponds to a transformation run that you have defined.

3 In the Max Subquery Size, type 3.

This number tells the Analyst Tool how to define queries for population and 
extraction during a transformation run.

4 Next to the Abstract Conceptual Model Schema field, click Browse to locate 
and select the file Abstract_Conceptual_Model_01.exp in the schema directory 
of your Modulant Curtana installation. 

5 Select the Group Output, Enforce Unique, and Left Join On Keys check boxes 
and ensure that the remaining check boxes are cleared.

6 Click OK to save your settings.

For more information about setting preferences for the Analyst Tool, see the 
Modulant Curtana Analyst Tool Guide.

Start the Modulant Balisarda Mapping Tool
Now you can start the Mapping Tool:

On the Design tab, click the Modulant Balisarda button.
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The Modulant Balisarda Mapping Tool starts in its own window:

Importing the ATS Schema
Before you can begin creating a mapping, you must tell the Mapping Tool which 
ATS schema you want to map. The easiest way to do this is to import an EXPRESS 
schema file. For more information about importing ATS schema information in a 
variety of formats, see Chapter 6, “Importing ATS Schema Information.”

Note: The ATS schema you will use in this example is in EXPRESS format. You 
can generate an EXPRESS schema by creating an EXPRESS-G diagram using 
FirstSTEP XG, or if you are familiar with the EXPRESS language, you can create 
one using a text editor. You can generate an XML DTD of the required format 
from your EXPRESS schema using FirstSTEP EXML. To obtain a copy of either of 
these tools, write to info@pdit.com.

To import the ATS schema for the AcmeAuto database:

1 Select File>Import>ATS Definition>From EXPRESS Schema.

mailto:info@pdit.com
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The Import ATS Definition From EXPRESS Schema dialog box appears:

2 In the Prefix for ATS field, type ACME.

The Mapping Tool prefixes this value to entries for this ATS in its internal 
database and in the mapping specification.

Note: Values for table prefixes are case-sensitive. Modulant recommends 
that you use all upper-case letters for table prefixes.

3 In the Abbreviated ATS Name field, type ACME.

The Mapping Tool uses this value as the name of a data element group. Data 
element groups identify the data elements in each ATS schema. When you 
create mappings for more than one ATS schema, the group name is an easy 
way to distinguish which data elements you are working with at any time.

4 In the Full ATS Name field, type ACMEAUTO.

The Mapping Tool uses this name to identify the ATS schema associated with 
the AcmeAuto database.

5 To locate the EXPRESS schema file:
a Click Browse next to the EXPRESS File Name field and navigate to the 

location of the EXPRESS schema for the AcmeAuto database. For this 
example, use the file acmeauto.exp in the samples\acmeauto directory of 
your Modulant Curtana installation.

b Select the EXPRESS schema file and click Open.
6 To locate the DTD associated with the EXPRESS schema file:

a Click Browse next to the DTD File Name field and navigate to the location 
of the DTD file for the AcmeAuto database. For this example, use the file 
acmeauto.dtd in the DTD directory of your Modulant Curtana installation.

b Select the DTD file and click Open.
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7 Click OK.

The Mapping Tool imports the schema information and constructs a list of 
data elements in your ATS schema. It uses the abbreviation you provided for 
the ATS name, in this case ACME, to create a data element group with all of the 
elements in the ATS schema you just imported. 

Note: The Mapping Tool imports this information without informing you 
when the import operation is complete.

Now you are ready to map the data elements in your ATS schema.

Mapping Data Elements
The process of mapping data elements from an ATS schema includes:

Mapping the Root Element

Mapping Related Data Elements

For more information about these stages, see Chapter 7, “Mapping Data 
Elements.”

Mapping the Root Element
To start your mapping, you map the root data element first. The root element is 
one that connects a group of other data elements, usually the key field of a 
database table. 

The mapping process expects a root element for each database table. In this case, 
you start with the key of the ACME_TRIM table, which is TRIM_NBR. According to 
Table 3 on page 23, you map this root element to product.id.

To map the root element:

1 Select Mapping>Add>Mapping Target.

The Specify Data Element dialog box appears. By default, the Data Element 
Name field shows the first data element (listed alphabetically, starting with 
COLOR_CODE) in your source ATS. Notice that the Data Element Group Name 
shows ACME.
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2 From the Data Element Name drop-down list, select ACME_TRIM: TRIM_NBR.

The value of the Mapping ID field changes to show the mapping ID of the data 
element you selected.

3 Click OK to continue to the next step.

The Select Mapping Target dialog box appears, showing the data element you 
just selected:

4 From the Entity drop-down list, select product.

When you select a target entity, the Attribute list shows only the attributes of 
that entity.

5 From the Attribute drop-down list, select id.
6 Click OK to map ACME_TRIM: TRIM_NBR to product.id.
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The Select Root Mapping dialog box appears, showing the mapping target 
you selected:

7 Click OK to identify TRIM_NBR and its mapping target as a root mapping for 
the ACME_TRIM table. 
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The Edit Structure Mapping dialog box appears:
+

8 Expand all of the nodes of the tree structure under Acme-006 (Mapping ID). 

The expanded view shows you the path to the mapping target you selected, 
known as the structure mapping:
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Notice that the product entity has an attribute called context_discipline_type. 
You use this attribute to specify the context of the product, so that it can be 
preserved through the transformation process. In other words, to more clearly 
identify this product, you provide a text string as the value of 
context_discipline_type that says what this product is about. This information 
is known as a domain constraint.

9 To specify the context of this product:
a In the structure mapping, select context_discipline_type.

The Mapping Tool fills in the table at the bottom of the dialog box with 
the names of the attributes of product and their types. You use this 
information to specify domain constraints.

b In the table at the bottom, select the Constraint cell of the 
context_discipline_type row.

c Click Constraints.
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The Add Constraints dialog box appears:

d Click Show Attribute Constraints to see a list of context strings you have 
already entered for this attribute. 
Because this will be your first context string, the list is empty at this point. 
This list will become important later in the mapping process.

e In the Constraint field, type Trim Package to identify the meaning of the 
ACME_TRIM table.
You can enter up to 255 characters for a domain constraint string. Shorter 
strings produce more efficient data transformations, but make sure to use 
a string that is long enough to convey all of the necessary information.

f Click OK.
The structure mapping now shows the context string you entered.



Mapping Data Elements

Modulant Balisarda Mapping Tool Guide 37

10 In the Edit Structure Mapping dialog box, click OK to accept the structure 
mapping.

You will see more examples of structure mappings as you map the remaining 
data elements of the AcmeAuto database.

Tip: You can select Edit>Structure Mapping to go back and change the 
structure mapping at any point in your mapping.

Mapping Related Data Elements
Once you have mapped the root element, you can map the elements related to 
that root. In a relational database, those are the other elements in the same table. It 
does not matter what order you use to map these elements.

The next step of this example is to map the remaining elements of the ACME_TRIM 
table: TRIM_NAME, TRIM_COLOR, COLOR_CODE, T_MAKE, and T_MODEL.

Mapping TRIM_NAME
To map TRIM_NAME:

1 Select Mapping>Add>Mapping Target.
2 In the Specify Data Element dialog box, select ACME_TRIM: TRIM_NAME, and 

click OK.

Notice that ACME_TRIM: TRIM_NBR no longer appears in the Data Element 
Name list.

3 In the Specify Mapping Target dialog box, select the mapping target 
product.name and click OK.

Tip: Select product from the Entity list, and then select name from the 
Attribute list.

4 In the Edit Structure Mapping dialog box, expand the structure mapping to 
show product and its attributes.

Because the data element TRIM_NAME refers to the same product as TRIM_NBR, 
you want to connect the product entity in this structure mapping to the 
product entity in the structure mapping you did for TRIM_NBR. To do this, you 
apply the same domain constraint to context_discipline_type.

5 To apply the domain constraint:
a Select the attribute context_discipline_type.
b In the table at the bottom, select the Constraint cell of the 

context_discipline_type row.
c Click Constraints.
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d In the Add Constraints dialog box, click Show Attribute Constraints.
When you want to enter a text string for an Abstract Conceptual Model 
element, the Mapping Tool displays a list of text strings you have already 
used for this attribute, so that you can select one from the list if one 
matches. This helps you ensure consistent mappings.
Notice that the string you entered for TRIM_NBR appears in the Constraints 
list.

e Select ‘Trim Package’ from the Constraints list, and click Add Selected 
Constraint.

Tip: You can double-click a constraint string to select it instead of clicking 
Add Selected Constraint.

f Click OK to accept the domain constraint value.
6 In the Edit Structure Mapping dialog box, click OK to accept the changes you 

made to the structure mapping.

Mapping TRIM_COLOR
To map TRIM_COLOR:

1 Select Mapping>Add>Mapping Target.
2 In the Specify Data Element dialog box, select ACME_TRIM: TRIM_COLOR, and 

click OK.
3 In the Select Mapping Target dialog box, select the mapping target 

group.name and click OK.
4 In the Edit Structure Mapping dialog box, expand the structure mapping to 

show group and its attributes.

Because you mapped the root element to an attribute of product and you 
mapped TRIM_COLOR to an attribute of group, you must connect these entities 
to complete the structure mapping. The Abstract Conceptual Model contains 
an entity called product_group_assignment that you can use for this. For more 
information about this entity, see “Product and Group” on page 94.

5 To add product_group_assignment to the structure mapping:
a In the structure mapping, select ACME 004 (Mapping ID) at the top.
b Click Add.
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The Add Entities to Structure Mapping dialog box appears:

c Under Abstract Conceptual Model Entities, expand Entities, then expand 
management data associations.
This folder lists all association entities related to the entities that appear in 
the structure mapping. For more information about association entities, 
see “Management Resource Associations” on page 88.

d Select product_group_assignment.
e Click OK to add this entity to the structure mapping.

Now you have a relationship between group and product, which is what you 
needed. Notice that the Mapping Tool added an entity you did not explicitly 
select: assignment_role. 

The assignment entities are all directly related to assignment_role. This entity 
has a name attribute that plays a critical part in establishing context for the 
data elements you map. For more information about this entity, see 
“Assignment Roles” on page 89.

6 Expand assignment_role.
7 Select the name attribute of assignment_role.
8 Following the instructions in step 9 on page 35, enter Trim Color as a 

domain constraint value for the name attribute.
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Tip: You can usually use the column name of the data element you are 
mapping for assignment_role.name, unless you need a more specific string. If 
you have two columns with different names that mean the same thing, 
however, be sure to use the same string for both.

9 Follow the instructions in step 5 on page 37 to specify ‘Trim Package’ as a 
domain constraint for product.context_discipline_type.

10 Click OK to finish the structure mapping for TRIM_COLOR.

Mapping COLOR_CODE
To map COLOR_CODE:

1 Select Mapping>Add>Mapping Target.
2 In the Specify Data Element dialog box, select ACME_TRIM: COLOR_CODE, and 

click OK.

Remember that color codes provide a way to classify the colors assigned to 
trim packages, and that the group entity in the Abstract Conceptual Model 
represents classification systems.

3 In the Select Mapping Target dialog box, select the mapping target 
group.name and click OK.

4 In the Edit Structure Mapping dialog box, expand the structure mapping to 
show group and its attributes.

As you did when you mapped TRIM_COLOR, you need to connect group to 
product.

5 Following the instructions in step 5 on page 38, add 
product_group_assignment to the structure mapping.

6 Expand assignment_role.
7 Following the instructions in step 5 on page 37, to specify ‘Trim Color’ as a 

domain constraint value for assignment_role.name.

The trim color provides a classification of the product. The color code 
provides a classification of trim colors, but is not directly related to products.

8 Follow the instructions in step 5 on page 37 to specify ‘Trim Package’ as a 
domain constraint for product.context_discipline_type.

Now you need to create a relationship between the two groups: color codes 
and trim colors. Trim colors will become a subgroup of color codes.

9 To relate the color code group to the trim color group:
a Select ACME-001 (Mapping ID) again and click Add.
b Expand Entities.
c Under management data resources, add two entities: group and 

group_relationship to the structure mapping. Notice that you are adding a 
second group entity to your mapping with this step.

Tip: Use CTRL+CLICK to select more than one entity.
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d Select and expand group_relationship.
e In the table at the bottom, change the value of the Instance ID cell for 

related_group to 2, and then click Modify.
This specifies the trim color group as the child group of the relationship, 
the color code group as the parent.

f Select group_relationship.name and click Constraints to specify a name for 
the group.

g Type Color classification as a domain constraint to specify the name 
of the group relationship.

h Select and expand product_group_assignment.
i In the table at the bottom, set the Instance ID of assigned_group to 2, and 

then click Modify.
This relates the trim color group back to the product entity.

10 In the Edit Structure Mapping dialog box, click OK to finish the structure 
mapping for COLOR_CODE.

Mapping T_MAKE
To map T_MAKE:

1 Select Mapping>Add>Mapping Target.
2 In the Specify Data Element dialog box, select ACME_TRIM: T_MAKE, and click 

OK.

The make of a car indicates who manufactured the car. Because the 
manufacturer of a car can be considered as an organization, you will use the 
organization entity in the Abstract Conceptual Model for this mapping.

3 In the Select Mapping Target dialog box, select the mapping target 
organization.identifier and click OK.

4 In the Edit Structure Mapping dialog box, expand the structure mapping to 
show organization and its attributes.

You must add an assignment entity that connects products with 
organizations. In this case, you will use product_organization_assignment to 
connect the current mapping target to the root. For more information about 
this entity, see “Product and Organization” on page 96.

5 Select ACME-002 (Mapping ID) and click Add.
6 Following the instructions in step 5 on page 38, add 

product_organization_assignment (in the management data associations 
folder) to the structure mapping.

Once again, the Mapping Tool added assignment_role to the structure 
mapping.

7 Following the instructions in step 9 on page 35, enter Make as a new domain 
constraint value for assignment_role.name.

8 Follow the instructions in step 5 on page 37 to select the existing value ‘Trim 
Package’ as a domain constraint for product.context_discipline_type.
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9 Click OK to finish the structure mapping for T_MAKE.

Mapping T_MODEL
To map T_MODEL:

1 Select Mapping>Add>Mapping Target.
2 In the Specify Data Element dialog box, select ACME_TRIM: T_MODEL, and click 

OK.

The model of a car provides a way of grouping cars from a single 
manufacturer. Therefore, you will once again use group as the mapping 
target. Notice that each of the groups you have defined (trim colors, color 
codes, and now models) represents a different classification schema, and are 
therefore different groups.

3 In the Select Mapping Target dialog box, select the mapping target 
group.name and click OK.

4 In the Edit Structure Mapping dialog box, expand the structure mapping to 
show group and its attributes.

As you did when you mapped TRIM_COLOR and COLOR_CODE, you need to 
connect group to product.

5 Following the instructions in step 5 on page 38, add 
product_group_assignment (in the management data associations folder) to 
the structure mapping.

Notice that the Mapping Tool again added assignment_role to the structure 
mapping.

6 Following the instructions in step 9 on page 35, enter Model as a new domain 
constraint value for assignment_role.name.

7 Follow the instructions in step 5 on page 37 to select the existing value ‘Trim 
Package’ as a domain constraint for product.context_discipline_type.

8 Click OK to finish the structure mapping for T_MODEL.
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Mapping the ACME_TRIM_IMAGE Table
You have now mapped the first table in the AcmeAuto database, ACME_TRIM. 
Mapping the elements in the ACME_TRIM_IMAGE table follows the same process. 
Use the information in Table 4 to map the elements in ACME_TRIM_IMAGE.

Table 4: Mapping the ACME_TRIM_IMAGE Table

Source Element Mapping Target Notes

ACME_TRIM_IMAGE: TRIM_NBR product.id This is the root element of the 
ACME_TRIM_IMAGE table. When you 
map this element, you must indicate 
that the target product entity is the 
same as the product that is the root of 
the ACME_TRIM table.

To do this, you set product.
context_discipline_type to the same 
string you used before (‘Trim Package’). 
For instructions, see step 9 on page 35.

ACME_TRIM_IMAGE: TRIM_NAME product.name Again, you must set the value of 
context_discipline_type to indicate that 
this refers to the same product as 
TRIM_NBR.

ACME_TRIM_IMAGE: IMAGE_TYPE document_type.
product_data_type

In the structure mapping, add the 
document entity first (from the 
management data resources folder), 
and then add the assignment entity 
product_document_reference (from the 
management data associations folder) 
to connect documents to products. 
Enter Image Type as the value of 
assignment_role.name.

Set the value of product.
context_discipline_type to ‘Trim Package’ 
as you did before.
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At this point, you have finished mapping the source data elements. If you select 
Mapping>Add>Mapping Target, the only data element left on the list is the one 
you did not map, ACME_TRIM_IMAGE.TRIM. For more information about structure 
mappings and the structure mapping process, see Chapter 7, “Mapping Data 
Elements.”

Now you are ready for the next step: defining the transformation.

Defining the Transformation
So far, you have mapped each data element individually and specified the 
structure mapping for each one. The next step is to specify how to transform the 
data associated with each element, based on the structure mappings. To do this, 
you connect database fields to Abstract Conceptual Model attributes in the 
structure mapping for each data element. 

This process helps consolidate the information about the structure of the data 
represented by your schema. By connecting the same data element with the same 
attributes in each structure mapping, you specify how you want the 
Transformation Engine to populate the Abstract Conceptual Model with input 
data and how you want it to extract output data from the Abstract Conceptual 
Model.

For example, you mapped ACME_TRIM: TRIM_NBR to product.id and 
ACME_TRIM: TRIM_NAME to product.name. When you use the Analyst Tool to 
perform transformation runs, you want the values of both TRIM_NBR and 
TRIM_NAME to always map to the same data fields, rather than creating duplicate 
copies of identical data, in different product entities. Defining the transformation 
ensures that your data comes out the way you expect it to.

ACME_TRIM_IMAGE: T_IMAGE document.id Add the assignment entity 
product_document_reference (from the 
management data associations folder). 
Enter Image File as the value of 
assignment_role.name.

Set the value of product.
context_discipline_type to ‘Trim Package’ 
as you did before.

ACME_TRIM_IMAGE: TRIM skip this one This attribute actually refers back to the 
ACME_TRIM table, which you have 
already mapped. 

Table 4: Mapping the ACME_TRIM_IMAGE Table

Source Element Mapping Target Notes
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Starting to Define the Transformation
To define the transformation:

1 Select Tools>Define Transformation.

The Define Transformation dialog box appears:

At the top is a drop-down list of the data element names you mapped. To 
define a complete transformation, you connect data elements from the list of 
data elements on the right to attributes in the structure mapping on the left. 
When no data element matches an attribute, you can specify a text string as 
the default value to use for that attribute in the transformation process. 

You can do this in any order. For simplicity, in this walkthrough, you will 
work on the elements in alphabetical order.

2 Expand all of the nodes in the structure mapping for the data element 
ACME_TRIM: COLOR_CODE.

3 In the structure mapping, select the name attribute of group(2). 
4 In the list of data elements, select TRIM_COLOR.
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5 Click Connect to map the selected elements to each other.

The structure mapping now shows the connected elements.

Because none of the source data elements provide further descriptive 
information about either group of colors, you supply a string to use as the 
default value when the Transformation Engine populates the Abstract 
Conceptual Model from the AcmeAuto database.

6 To specify a default value:
a Select the first group.description, and click Default Value.

The Modify Default Values dialog box appears:

b Select the first row that contains group.description.
c Click Assign Default Value, to use the string ‘No data available’ as the 

default value for this field.
7 Select the rows that contain the second group.description, 

group_relationship.description, and product.description, and click Assign 
Default Value to assign the same default value to each of them.

Tip: Use CTRL+CLICK to select more than one entity.

8 Click OK to return to the Define Transformation dialog box.

The structure mapping now shows the default values you specified.

9 Connect product.name to TRIM_NAME.
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When you are done, the structure mapping should look like this:

10 Click Apply to save your changes.

Continuing to Define the Transformation
You must repeat this process for the structure mapping for each data element you 
mapped. 

To continue the process:

1 From the Data Element Name drop-down list, select the next data element, in 
this case, ACME_TRIM: T_MAKE.

2 Expand all of the nodes of the structure mapping.
3 Connect the elements as follows:

organization.name T_MAKE

product.name TRIM_NAME
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4 Set the text string ‘No data available’ as the default value for the following 
elements:

organization.address 
organization.description 
product.description

5 Select the next data element, ACME_TRIM: T_MODEL.
6 Click Yes to commit your changes.
7 Connect the elements as follows:

8 Connect TRIM_COLOR as follows:

9 Connect TRIM_NAME as follows:

10 Connect TRIM_NBR as follows:

You have now completed the transformation definition for the ACME_TRIM 
table.

11 Use the following tables to define the transformation for the 
ACME_TRIM_IMAGE table.
a To connect ACME_TRIM_IMAGE: TRIM_NBR:

b To connect ACME_TRIM_IMAGE: TRIM_NAME:

group.id T_MODEL

group.description ‘No data available’ 

product.name TRIM_NAME

product.description ‘No data available’ 

group.description ‘No data available’ 

product.name TRIM_NAME

product.description ‘No data available’ 

product.description ‘No data available’ 

product.name TRIM_NAME

product.description ‘No data available’ 

product.name TRIM_NAME

product.description ‘No data available’ 

product.description ‘No data available’ 
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c To connect ACME_TRIM_IMAGE: T_IMAGE:

d To connect ACME_TRIM_IMAGE: IMAGE_TYPE:

12 Click Apply, and then click Close to save your changes and complete the 
process.

Creating a Mapping Specification
After you finish defining the transformation, you are ready to generate the 
mapping specification. You will be able to use this specification with the Analyst 
Tool to perform transformation runs.

To create the mapping specification:

1 Select Tools>Generate Transformation Map.

The Transformation Map Instance Number dialog box appears:

2 Click OK to accept the default value of 1 as the starting global instance 
number.

This number is related to how you will use the mapping specification when 
you perform transformation runs. The Mapping Tool lets you know when the 
map has been successfully generated.

document.name T_IMAGE

document.description ‘No data available’ 

document_type.product_data_type IMAGE_TYPE

product.name TRIM_NAME

product.description ‘No data available’

document.id T_IMAGE

document.name T_IMAGE

document.description ‘No data available’ 

product.name TRIM_NAME
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The Mapping Tool uses the mapping and transformation information you 
provided to generate a mapping specification, which you can export into an XMP 
(XML MaP) file. For more information about the format of XMP files, including 
the DTD, see Appendix B, “XMP Reference.”

Optimizing a Mapping Specification
When you are satisfied that your mappings work the way you want them to, it is 
time to optimize the mapping specification. This will result in better performance 
by the Transformation Engine, and will minimize redundant data. 

To optimize your mapping specification:

Select Tools>Optimize Transformation Map.

The optimization process scans your mapping specification and consolidates 
references to the same data elements. Note that this process can take a while.

Exporting an XMP File
To use the mapping specification with the Analyst Tool or the Lifecycle Manager 
API, you can export the mapping information from the Mapping Tool’s internal 
database to an XMP file in XML format. 

To export an XMP file:

1 Select File>Export>XMP.

The Export XMP File dialog box appears:

2 Click Browse to specify the location where you want to save the XMP file, and 
specify a file name. Use the extension .xml.

Tip: Modulant recommends that you include the letters xmp in your file 
name to identify the file as a mapping specification; for example, 
myfile-xmp.xml.

3 From the ATS Name drop-down list, select the ATS schema whose mappings 
you want to save.

4 Click OK.

When the export operation is complete, click OK to continue.
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Tip: The file acme-xmp.xml in the samples\acmeauto directory of your 
Modulant Curtana installation contains all of the mappings you created in 
this walkthrough.

You can use the generated XMP file with both the Analyst Tool and the 
Lifecycle Manager API. For more information, see the Modulant Curtana 
Analyst Tool Guide and the Modulant Curtana Developer’s Guide.

Testing a Mapping Specification
To test your mapping specification, use the Analyst Tool to do a transformation 
run using the AcmeAuto ATS as both the source and the target. To do this, you 
can use the same XMP file for both parts of the transformation. 

The test includes the following steps:

Importing AcmeAuto Data

Performing the Transformation Run

Understanding the Results of the Transformation

Cleaning Up the Internal Database

Importing AcmeAuto Data
Before you can perform a transformation run, you must import the data from 
your ATS into the Modulant Curtana internal database. The AcmeAuto database 
is in the samples\acmeauto directory of your Modulant Curtana installation, in the 
file acmeauto.mdb.

To import data from the AcmeAuto database:

1 Select File>Exit to close the Mapping Tool.
2 In the Modulant Curtana Analyst Tool, select File>Import Data>From 

Database Tables.
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The Import Database Tables dialog box appears:

3 Click Add To List to browse for the location of your database. In this case, 
select samples\acmeauto\acmeauto.mdb in your Modulant Curtana 
installation, and click Open.

The name of the database you selected, and the full path to its location, 
appears in the Selected Databases list.

4 Click OK to continue.

The Analyst Tool reads the definition of your ATS schema and looks for tables 
in the selected database that match the names of ATS entities. In this case, the 
first ATS entity is ACME_ACME_TRIM, whose name could match both tables in 
the database.
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The Select Database Tables to Import dialog box appears:

Because two tables in your database might match the ATS entity 
ACME_ACME_TRIM (listed at the top of the dialog box), you must specify 
which of these tables actually matches.

Note: If the Analyst Tool finds no ambiguity in the names of the tables in 
your database, it imports the data automatically without showing you this 
dialog box.

5 Select the ACME_ACME_TRIM table and click OK.

After importing the data from this table, the Analyst Tool finds that the next 
entity in the ATS definition is ACME_ACME_TRIM_IMAGE. Because the 
database you selected has a table that matches this name exactly, the Analyst 
Tool imports the data from this table automatically.

6 When the import is complete, click OK to proceed.

The data from both tables in the AcmeAuto database is now in the internal 
database, where it is ready for processing.
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Performing the Transformation Run
To do a test transformation run:

1 On the Run tab, click the Integrate button.

The Integrate dialog box appears:

2 To define a configuration name for this transformation run:
a At the top of the dialog box, click Add.
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The Add New Configuration dialog box appears:

b In the Configuration Name field, type test.
c Under both Input Transactions and Output Transactions, select ACMEAUTO.
d Leave the Output Table Prefix and the Output Query Prefix fields blank.

The Analyst Tool will use the existing prefixes for the ATSs you selected.
e Click OK.

3 In the Integrate dialog box:
a Make sure test is selected from the Configuration Name list.

The Data Element Names list at the bottom now shows any data elements 
in your output ATS (in this case AcmeAuto) that have been mapped and 
whose mapping usage is either Output or Input/Output.

b Select all of the data elements in this list.
The Transformation Engine will extract data for all of the data elements 
you select.
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The Integrate dialog box now shows the configuration information you 
specified:

4 Click Execute to start the transformation run.
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Understanding the Results of the Transformation
When the transformation run has finished, the Analyst Tool displays the View ATS 
dialog box.

1 To view the source and target data, which is still in the internal database:
a Under ATS Names, select ACMEAUTO.
b In the Table Names list, select ACME_ACME_TRIM and 

ACME_ACME_TRIM_IMAGE.
c Click View Selected Tables.
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A copy of the View Table dialog box appears for each table you selected, 
with the name of the table in the title bar:

The reqID column shows the number of the transformation run. Entries with 
the number followed by out represent target ATS data—the result of the 
transformation.

2 To verify the results of the transformation:
a Check that you have the same number of rows of input data as you do of 

output data.
b Check each column in the table to see that wherever there is input data, 

there is corresponding output data and that the values match.

For more information about testing your mapping specification using the Analyst 
Tool in a transformation run, see the Modulant Curtana Analyst Tool Guide.

Cleaning Up the Internal Database
If you want to perform the same transformation more than once, you must run 
the Clean Up Tool after each transformation run. For information about this tool, 
see the Modulant Curtana Analyst Tool Guide.
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