
Importing ATS Schemas
You can import ATS schema information from:

EXPRESS models
File>Import>ATS Definition>From EXPRESS 
Schema 
CSV (comma-separated values) files:

Table definitions: database structure only
File>Import>ATS Definition>From CSV File 
Data element definitions: logical and physical 
descriptions of data structures
File>Import>Data Element Definitions 
Data element maps: logical and physical 
descriptions, as well as mapping targets 
File>Import>Data Element Maps

XMP (XML MaP) files
a Select File>Import>XMP and locate the file.
b Select Tools>Generate Transformation Map.

When you import an ATS definition from an EXPRESS 
model or an XMP file, the Mapping Tool defines the 
mapping infrastructure for you. Otherwise, you must 
set up the infrastructure yourself.

Defining Mapping Infrastructure

In order to create mappings, you need:
A data element group for each ATS
a Select Mapping>Add>Data Element Group.
b Specify a name and an optional description. 
c To add data elements based on your ATS, click 

Build Names from ATS Definition.
d Or, fill in the information about individual data 

elements to add. 
Registration with an Abstract Conceptual Model 
schema for each data element group
Edit>Register Abstract Conceptual Model
An entry in the ATS Registry
a Select File>Exit to close the Modulant Balisarda 

Mapping Tool and return to the Analyst Tool.
b In the Analyst Tool, select Design>ATS 

Registry.
c Fill in the ATS Name, DTD Name, and Table 

Prefix fields.
d Fill in the Source Data Element Group Name and 

the Target Data Element Group Name.
e Leave the ATS Group Name field blank.

Modifying the ATS Definition

To modify the ATS definition, you must:
1 Add new attributes to the ATS definition

Edit>ATS Definition
2 Define the new attributes as data elements

Mapping>Add>Data Element

Mapping Data Elements
The Mapping Tool stores mapping information and data 
converter specifications in the XMP file.

Specifying the Mapping Target
1 Select Mapping>Add>Mapping Target.
2 Select a data element and its mapping target.
3 To specify more than one mapping target, click 

Complex Mapping instead of OK.
4 In the Select Root Mapping dialog box, click OK or 

Skip.

About Complex Mappings

When a data element can have more than one 
functionally equivalent meaning:

Value Equal: mapping usage always Input 
OR Extraction: mapping usage always Output 

If necessary, change the mapping usage in the XMP 
from I or O to B to use for both input and output.

Completing the Structure Mapping

The structure mapping represents the relationships 
between the mapping target and the root mapping. 
1 To add one or more entities, select the mapping ID 

at the top of the tree structure and click Add.
Product Identification/Definition: all aspects of a 
product and its relationships to other products
Product Property/Representation: properties of 
products and how they are represented
Management Resources: applies to other types of 
entities (such as people and groups)
Management Resource Associations: associates 
Management Resources to Product Information

2 If necessary, change the Instance ID value for 
attributes of the new entities you added.

To modify an existing structure mapping:
Select Edit>Structure Mapping.

Specifying Context
1 In the structure mapping, select the entity for which 

you want to specify a domain constraint.
2 In the table at the bottom, select the Constraint cell 

for an attribute of that entity and click Constraints. 
3 Type a constraint string or select an existing one.

Defining the Transformation
Fills in the “holes” in structure mappings.
1 Select Tools>Define Transformation.
2 Select an ACM attribute in the structure mapping and 

an associated ATS attribute from the list on the right 
and click Connect.

Using the Data Converter
To use the Data Converter, you do the following:
1 Identify where you need data conversion.
2 Create and map any new data elements needed. 
3 Export an XMP file (File>Export>XMP). 
4 Add conversion specifications to the XMP file.

<xmp>
...
<dataConverter>

<conversionList name="PREPROCESSOR">
</conversionList>
<conversionList name="POSTPROCESSOR">
</conversionList>

</dataConverter>
</xmp>

Each conversionList has one or more conversion 
elements, of one of the following types:

EXTRACTSUBSTR (extract by substring position)
Use extraction by substring position if you know the 
offset position where you want to split a field.

To extract the month portion:
<conversion type="EXTRACTSUBSTR" table="Person">

<output>
<column name="HMonth" type="varchar(2)"/>

</output>
<param name="input">

<column name="HDate"/>
</param>
<param name="start">

<constant value="1"/>
</param>
<param name="length">

<constant value="2"/>
</param>

</conversion>

EXTRACTDELIM (extract by delimiter character)
Use extraction by delimiter to split a field after a 
particular character or character string.

To extract the first name:
<conversion type="EXTRACTDELIM" table="Person">

<output>
<column name="FirstName" type="varchar(50)"/>

</output>

Input Output

HDate HDay HMonth HYear

‘07/09/2001’ 9 7 2001

Input Output

Name FirstName LastName

‘Doe#Jane’ ‘Jane’ ‘Doe’



<param name="input">
<column name="Name"/>

</param>
<param name="delim">

<constant value="#"/>
</param>
<param name="token">

<constant value="2"/>
</param>

</conversion>

CONCAT (concatenation)
Use concatenation to combine two or more fields.

To combine the date components to a single field:
<conversion type="CONCAT" table="Person">

<output>
<column name="HDate" type="char(10)"/>

</output>
<param name="input">

<column name="HDay"/>
<column name="HMonth"/>
<column name="HYear"/>

</param>
<param name="delim">

<constant value="/"/>
</param>
<param name="trim">

<constant value="Y"/>
</param>

</conversion>

ARITHMETIC (arithmetic calculation)
Use arithmetic calculations (addition, subtraction, 
multiplication, and division) to derive new fields.

To calculate the price of a 10% discount:
<conversion type="ARITHMETIC" table="Product">

<output>
<column name="SalePrice" type="varchar(4)"/>

</output>
<param name="expression">

<constant value="? * (1 – ?/100)"/>
</param>
<param name="input">

<column name="Price"/>
<column name="Discount"/>

</param>
</conversion>

Input Output

HDay HMonth HYear HDate

‘09’ ‘12’ ‘1987’ ‘09/12/1987’

Input Output

Price Discount SalePrice

50 10 45

Troubleshooting
PopulationException error
Possible Solutions:

Generate Transformation Map after importing XMP 
Match the Request ID value in the source data

TransformationException error
Possible Solutions:

Import target data structure
Examine and correct data converter specifications

Too many rows of output data
Possible Solutions:

Make sure domain constraints are consistent
Review connections in structure mappings
Set Enforce Unique and Group Output in 
Preferences and Enforce ATS Keys in Integrate 
dialog box

Not enough rows of output data
Possible Solutions:

Check input data for validity and fix any problems
Review connections in structure mappings
Examine and modify domain constraints

Duplicated rows of output data
Possible Solutions:

Decide that extra data is not really a problem
Set Enforce ATS Keys in Integrate dialog box and 
Group Output in Preferences 

Missing output data (empty columns)
Possible Solutions:

Review error log
Examine and modify domain constraints
Review connections in structure mappings 
In the XMP, verify that tableName and fieldName 
attributes of dataElement elements match the 
physical schema

Strange (wrong) data values
Possible Solutions:

Review input data and fix any problems

Extra output columns
Possible Solutions:

Review data converter specifications in the XMP file
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Modulant Balisarda Mapping Tool
Quick Reference

Starting the Mapping Tool
Before you can start the Mapping Tool, you must:
1 Start the Analyst Tool:

Start>Programs>Modulant>Modulant Curtana

2 Define a database connection: 
a Next to Database Connection, click Edit.
b Specify a name and login information.
c Click Add to add the connection to the list.
d Click Close.

3 Set the system configuration:
a Select Design>Preferences.
b Set the preferences as follows:

4 Select Design>Modulant Balisarda.

Next Request ID A number for a 
transformation run that you 
have defined

Max Subquery Size Always type 3 

Abstract Conceptual 
Model Schema

Browse to locate ACM 
schema file

Strict Data Retrieve Do not return blanks

Group Output* Returns the maximum value 
for the combination of keys

Clean Up* Removes transient tables 
and queries

Use Default Value Places the default value the 
target ATS if no data

Enforce Unique* Uses “unique” attributes of 
ACM entities as keys

Left Join On Keys* Uses the intersection of 
database table keys, plus 
the records that match the 
keys

Delete Imported 
Source Data

Removes all data imported 
from source ATSs

* = recommended settings



Importing ATS Schemas
You can import ATS schema information from:

EXPRESS models
File>Import>ATS Definition>From EXPRESS 
Schema 
CSV (comma-separated values) files:

Table definitions: database structure only
File>Import>ATS Definition>From CSV File 
Data element definitions: logical and physical 
descriptions of data structures
File>Import>Data Element Definitions 
Data element maps: logical and physical 
descriptions, as well as mapping targets 
File>Import>Data Element Maps

XMP (XML MaP) files
a Select File>Import>XMP and locate the file.
b Select Tools>Generate Transformation Map.

When you import an ATS definition from an EXPRESS 
model or an XMP file, the Mapping Tool defines the 
mapping infrastructure for you. Otherwise, you must 
set up the infrastructure yourself.

Defining Mapping Infrastructure

In order to create mappings, you need:
A data element group for each ATS
a Select Mapping>Add>Data Element Group.
b Specify a name and an optional description. 
c To add data elements based on your ATS, click 

Build Names from ATS Definition.
d Or, fill in the information about individual data 

elements to add. 
Registration with an Abstract Conceptual Model 
schema for each data element group
Edit>Register Abstract Conceptual Model
An entry in the ATS Registry
a Select File>Exit to close the Modulant Balisarda 

Mapping Tool and return to the Analyst Tool.
b In the Analyst Tool, select Design>ATS 

Registry.
c Fill in the ATS Name, DTD Name, and Table 

Prefix fields.
d Fill in the Source Data Element Group Name and 

the Target Data Element Group Name.
e Leave the ATS Group Name field blank.

Modifying the ATS Definition

To modify the ATS definition, you must:
1 Add new attributes to the ATS definition

Edit>ATS Definition
2 Define the new attributes as data elements

Mapping>Add>Data Element

Mapping Data Elements
The Mapping Tool stores mapping information and data 
converter specifications in the XMP file.

Specifying the Mapping Target
1 Select Mapping>Add>Mapping Target.
2 Select a data element and its mapping target.
3 To specify more than one mapping target, click 

Complex Mapping instead of OK.
4 In the Select Root Mapping dialog box, click OK or 

Skip.

About Complex Mappings

When a data element can have more than one 
functionally equivalent meaning:

Value Equal: mapping usage always Input 
OR Extraction: mapping usage always Output 

If necessary, change the mapping usage in the XMP 
from I or O to B to use for both input and output.

Completing the Structure Mapping

The structure mapping represents the relationships 
between the mapping target and the root mapping. 
1 To add one or more entities, select the mapping ID 

at the top of the tree structure and click Add.
Product Identification/Definition: all aspects of a 
product and its relationships to other products
Product Property/Representation: properties of 
products and how they are represented
Management Resources: applies to other types of 
entities (such as people and groups)
Management Resource Associations: associates 
Management Resources to Product Information

2 If necessary, change the Instance ID value for 
attributes of the new entities you added.

To modify an existing structure mapping:
Select Edit>Structure Mapping.

Specifying Context
1 In the structure mapping, select the entity for which 

you want to specify a domain constraint.
2 In the table at the bottom, select the Constraint cell 

for an attribute of that entity and click Constraints. 
3 Type a constraint string or select an existing one.

Defining the Transformation
Fills in the “holes” in structure mappings.
1 Select Tools>Define Transformation.
2 Select an ACM attribute in the structure mapping and 

an associated ATS attribute from the list on the right 
and click Connect.

Using the Data Converter
To use the Data Converter, you do the following:
1 Identify where you need data conversion.
2 Create and map any new data elements needed. 
3 Export an XMP file (File>Export>XMP). 
4 Add conversion specifications to the XMP file.

<xmp>
...
<dataConverter>

<conversionList name="PREPROCESSOR">
</conversionList>
<conversionList name="POSTPROCESSOR">
</conversionList>

</dataConverter>
</xmp>

Each conversionList has one or more conversion 
elements, of one of the following types:

EXTRACTSUBSTR (extract by substring position)
Use extraction by substring position if you know the 
offset position where you want to split a field.

To extract the month portion:
<conversion type="EXTRACTSUBSTR" table="Person">

<output>
<column name="HMonth" type="varchar(2)"/>

</output>
<param name="input">

<column name="HDate"/>
</param>
<param name="start">

<constant value="1"/>
</param>
<param name="length">

<constant value="2"/>
</param>

</conversion>

EXTRACTDELIM (extract by delimiter character)
Use extraction by delimiter to split a field after a 
particular character or character string.

To extract the first name:
<conversion type="EXTRACTDELIM" table="Person">

<output>
<column name="FirstName" type="varchar(50)"/>

</output>

Input Output

HDate HDay HMonth HYear

‘07/09/2001’ 9 7 2001

Input Output

Name FirstName LastName

‘Doe#Jane’ ‘Jane’ ‘Doe’



<param name="input">
<column name="Name"/>

</param>
<param name="delim">

<constant value="#"/>
</param>
<param name="token">

<constant value="2"/>
</param>

</conversion>

CONCAT (concatenation)
Use concatenation to combine two or more fields.

To combine the date components to a single field:
<conversion type="CONCAT" table="Person">

<output>
<column name="HDate" type="char(10)"/>

</output>
<param name="input">

<column name="HDay"/>
<column name="HMonth"/>
<column name="HYear"/>

</param>
<param name="delim">

<constant value="/"/>
</param>
<param name="trim">

<constant value="Y"/>
</param>

</conversion>

ARITHMETIC (arithmetic calculation)
Use arithmetic calculations (addition, subtraction, 
multiplication, and division) to derive new fields.

To calculate the price of a 10% discount:
<conversion type="ARITHMETIC" table="Product">

<output>
<column name="SalePrice" type="varchar(4)"/>

</output>
<param name="expression">

<constant value="? * (1 – ?/100)"/>
</param>
<param name="input">

<column name="Price"/>
<column name="Discount"/>

</param>
</conversion>

Input Output

HDay HMonth HYear HDate

‘09’ ‘12’ ‘1987’ ‘09/12/1987’

Input Output

Price Discount SalePrice

50 10 45

Troubleshooting
PopulationException error
Possible Solutions:

Generate Transformation Map after importing XMP 
Match the Request ID value in the source data

TransformationException error
Possible Solutions:

Import target data structure
Examine and correct data converter specifications

Too many rows of output data
Possible Solutions:

Make sure domain constraints are consistent
Review connections in structure mappings
Set Enforce Unique and Group Output in 
Preferences and Enforce ATS Keys in Integrate 
dialog box

Not enough rows of output data
Possible Solutions:

Check input data for validity and fix any problems
Review connections in structure mappings
Examine and modify domain constraints

Duplicated rows of output data
Possible Solutions:

Decide that extra data is not really a problem
Set Enforce ATS Keys in Integrate dialog box and 
Group Output in Preferences 

Missing output data (empty columns)
Possible Solutions:

Review error log
Examine and modify domain constraints
Review connections in structure mappings 
In the XMP, verify that tableName and fieldName 
attributes of dataElement elements match the 
physical schema

Strange (wrong) data values
Possible Solutions:

Review input data and fix any problems

Extra output columns
Possible Solutions:

Review data converter specifications in the XMP file
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Modulant Balisarda Mapping Tool
Quick Reference

Starting the Mapping Tool
Before you can start the Mapping Tool, you must:
1 Start the Analyst Tool:

Start>Programs>Modulant>Modulant Curtana

2 Define a database connection: 
a Next to Database Connection, click Edit.
b Specify a name and login information.
c Click Add to add the connection to the list.
d Click Close.

3 Set the system configuration:
a Select Design>Preferences.
b Set the preferences as follows:

4 Select Design>Modulant Balisarda.

Next Request ID A number for a 
transformation run that you 
have defined

Max Subquery Size Always type 3 

Abstract Conceptual 
Model Schema

Browse to locate ACM 
schema file

Strict Data Retrieve Do not return blanks

Group Output* Returns the maximum value 
for the combination of keys

Clean Up* Removes transient tables 
and queries

Use Default Value Places the default value the 
target ATS if no data

Enforce Unique* Uses “unique” attributes of 
ACM entities as keys

Left Join On Keys* Uses the intersection of 
database table keys, plus 
the records that match the 
keys

Delete Imported 
Source Data

Removes all data imported 
from source ATSs

* = recommended settings


